≡ Menu

Fix Secure Boot isn’t configured correctly Error after installing Windows 8.1

windows 8.1
It's only fair to share...Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedInPin on PinterestShare on VKShare on RedditPrint this pageEmail this to someone

Another error widely reported among Windows 8.1 users after upgrading is the error “Secure Boot isn’t configured correctly”.

If you want to find the reason, check you event log. Run -> eventvwr.exe -> Applications and Services Logs -> Microsoft -> Windows -> VerifyHardwareSecurity -> Admin. Check if the logged events points towards the options below.

  • Secure Boot is currently disabled. Please enable Secureboot through the system firmware. (The PC is in UEFI mode and Secure Boot is disabled.)
  • A non-production Secure Boot Policy was detected. Remove Debug/PreRelease policy through the system firmware. (The PC has a non-production policy.)

Secure Boot isn’t configured correctly can be fixed by

  • Go to BIOS, go to secure boot options
  • Enable secure boot
  • Check “Install Intel platform key”
  • Save the settings and restart computer
  • If the message “Secure Boot isn’t configured correctly” is still there, you need to update your BIOS.

Hope you find this helpful.

It's only fair to share...Share on FacebookShare on Google+Tweet about this on TwitterShare on LinkedInPin on PinterestShare on VKShare on RedditPrint this pageEmail this to someone

About the author: Anup Raman A Tech Enthusiast|Blogger|Tech Trainer with 10+ yrs experience in the field of IT. My expertise are in Operating Systems, mainly Windows and Computer security which comes from my experience, working as Tech Support and Trainer for Microsoft, Symantec and McAfee. Loves blogging about Technical Troubleshooting, discussing latest Gadgets, Games and doing Reviews.

{ 0 comments… add one }

Leave a Comment

Show Buttons
Hide Buttons